What’s Vulnerable › Vulnerabilities
CVE-2026-19073: Order Sync with Zendesk for WooCommerce < 2.2.3 - Unauthenticated Customer Order Data Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-200
Description
The Order Sync with Zendesk for WooCommerce WordPress plugin before 2.2.3 does not perform any capability check on one of its REST API endpoints, and does not verify that the requester owns the account being queried, allowing unauthenticated attackers to retrieve the order history and purchase totals of any customer whose email address they know or can enumerate.
Affected products
- Order Sync with Zendesk for WooCommerce: before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: Order Sync with Zendesk for WooCommerce 2.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19073 or the next vulnerability affects your stack