What’s Vulnerable › Vulnerabilities
CVE-2026-19094: Tutor LMS < 4.0.6 - Unauthenticated SQLi via 'offset' and 'item_per_page' Parameters
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-26
- Weakness: CWE-89
Description
The Tutor LMS WordPress plugin before 4.0.6 does not validate values used to build a database query, and does not restrict which template file a request may load, allowing unauthenticated users to inject SQL and to read question and answer content belonging to courses that are not publicly available. The injected text reaches the query as grammar rather than as data, and on the database engines tested it does not yield extraction of arbitrary data, so the confidentiality impact is the disclosed course content rather than the database at large.
Affected products
- themeum Tutor LMS – eLearning and online course solution: from 4.0.0 before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 4.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19094 or the next vulnerability affects your stack