What’s Vulnerable › Vulnerabilities
CVE-2026-19116: WP User Frontend < 4.3.11 - Subscriber+ PHP Object Injection via Frontend Post Edit Form
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-502
Description
The User Frontend WordPress plugin before 4.3.11 does not prevent user-supplied field values from being deserialized when a submitted post is reopened in its frontend editing form, allowing authenticated users with subscriber-level access and above to perform PHP Object Injection, which may lead to remote code execution when a suitable gadget chain is present on the site.
Affected products
- User Frontend: before 4.3.11 — fixed in 4.3.11
How to fix
Upgrade to a fixed version: User Frontend 4.3.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19116 or the next vulnerability affects your stack