What’s Vulnerable › Vulnerabilities
CVE-2026-19200: Velociraptor Analyst overwrites live built-in artifacts through verify()
- Severity: high (CVSS 8.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-94
Description
The Velociraptor verify() VQL function allows a user to verify an artifact for syntatic and other issues. Due to an implementation fault in this VQL function, the global artifact repository is used which allows callers to overwrite existing artifacts without the required permissions. The attacker need only have the NOTEBOOK_EDIT permission (e.g. an analyst role) to be able to call this function.
Affected products
- Rapid7 Velociraptor: before 0.77.2 — fixed in 0.77.2
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.77.2. Check the vendor advisory for mitigations.
References
- http://docs.velociraptor.app/announcements/advisories/cve-2026-19200/
- https://github.com/Velocidex/velociraptor/pull/4962
Get alerted when CVE-2026-19200 or the next vulnerability affects your stack