What’s Vulnerable › Vulnerabilities
CVE-2026-19217: Royal Elementor Addons < 1.7.1065 - Contributor+ Stored XSS via Icon Box Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-79
Description
The Royal Addons for Elementor WordPress plugin before 1.7.1065 does not validate a widget setting used to build an HTML tag before outputting it, which could allow users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Royal Addons for Elementor: before 1.7.1065 — fixed in 1.7.1065
How to fix
Upgrade to a fixed version: Royal Addons for Elementor 1.7.1065. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19217 or the next vulnerability affects your stack