What’s Vulnerable › Vulnerabilities
CVE-2026-19222: Forminator Forms < 1.57.0.7 - Authenticated Privilege Escalation via Registration Form Role Bypass
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-22 · updated 2026-10-12
- Weakness: CWE-269
Description
The Forminator Forms WordPress plugin before 1.57.0.7 does not consistently enforce the role restriction it applies to registration forms, allowing users who are permitted to build forms to configure one that assigns the administrator role to any visitor who registers through it.
Affected products
- wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder: before 1.57.0.7 — fixed in 1.57.0.7
How to fix
Upgrade to a fixed version: wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder 1.57.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19222 or the next vulnerability affects your stack