What’s Vulnerable › Vulnerabilities
CVE-2026-19226: Royal Elementor Addons < 1.7.1066 - Contributor+ Stored XSS via Image Accordion Widget Effect Settings
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-26
- Weakness: CWE-79
Description
The Royal Addons for Elementor WordPress plugin before 1.7.1066 does not validate some widget settings before outputting them inside an HTML attribute, which could allow users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Royal Addons for Elementor: before 1.7.1066 — fixed in 1.7.1066
How to fix
Upgrade to a fixed version: Royal Addons for Elementor 1.7.1066. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19226 or the next vulnerability affects your stack