What’s Vulnerable › Vulnerabilities
CVE-2026-19253: Cache Enabler < 1.8.17 - Unauthenticated Arbitrary File and Directory Deletion via cache_enabler_clear_page_cache_by_url
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-73
Description
The Cache Enabler WordPress plugin before 1.8.17 does not validate a URL before using it to build a filesystem path in its cache purge routine, and does not confine the resulting deletion to the cache directory, allowing unauthenticated users to delete arbitrary files and directories on sites where another installed Cache Enabler WordPress plugin before 1.8.17 or passes a request-derived URL to its public cache-clearing hook.
Affected products
- Cache Enabler: before 1.8.17 — fixed in 1.8.17
How to fix
Upgrade to a fixed version: Cache Enabler 1.8.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19253 or the next vulnerability affects your stack