What’s Vulnerable › Vulnerabilities
CVE-2026-19300: Langflow is vulnerable to information disclosure due to cross-user MCP tool cache collision and incomplete secret scrubbing on public flows
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-08
- Weakness: CWE-200
Description
IBM Langflow OSS 1.0.0 through 1.11.2 could allow a remote attacker to obtain sensitive information due to incomplete scrubbing of sensitive credential fields.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19300 or the next vulnerability affects your stack