What’s Vulnerable › Vulnerabilities

CVE-2026-19302: Langflow is vulnerable to arbitrary local file read due to path traversal in ChatInput, bundle FileInput, and GitExtractor components

Description

IBM Langflow OSS 1.0.0 through 1.11.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of symbolic links.

Affected products

How to fix

Upgrade to a fixed version: IBM Langflow OSS 1.11.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-19302 or the next vulnerability affects your stack