What’s Vulnerable › Vulnerabilities
CVE-2026-19406: Easy Appointments < 4.0.1 - Contributor+ Sensitive Information Disclosure via REST Appointments Listing
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-22
- Weakness: CWE-200
Description
The Easy Appointments WordPress plugin before 4.0.1 does not restrict one of its appointment-listing REST endpoints to the records belonging to the requesting user, allowing users with contributor-level access to read all bookings on the site, including customer names, schedules, and statuses.
Affected products
- Easy Appointments: from 3.12.28 before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Easy Appointments 4.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19406 or the next vulnerability affects your stack