What’s Vulnerable › Vulnerabilities
CVE-2026-19478: Improper Control of Generation of Code ('Code Injection') in GitLab
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-17 · updated 2026-09-02
- Weakness: CWE-94
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.11.11, 19.0 before 19.0.8, 19.1 before 19.1.6, and 19.2 before 19.2.4 that under certain conditions could allow an unauthenticated user to remotely modify or delete public projects and user data via a GraphQL directive.
Affected products
- GitLab: from 18.2.0 before 18.11.11; from 19.0.0 before 19.0.8; from 19.1.0 before 19.1.6; from 19.2.0 before 19.2.4 — fixed in 18.11.11, 19.0.8, 19.1.6, 19.2.4
How to fix
Upgrade to a fixed version: GitLab 18.11.11, 19.0.8, 19.1.6, 19.2.4. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-2-4-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/611377
- https://hackerone.com/reports/3926431
Get alerted when CVE-2026-19478 or the next vulnerability affects your stack