What’s Vulnerable › Vulnerabilities
CVE-2026-19484: @fastify/busboy vulnerable to Denial of Service via oversized multipart boundary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-03
- Weakness: CWE-835
Description
@fastify/busboy is a multipart form-data parser. In versions 3.1.0 through 3.2.0, a remote unauthenticated attacker can stall the Node.js event loop by sending a multipart request whose boundary is crafted to a specific length. The vendored streaming search stores its skip table in a fixed 256 entry byte array, and a boundary of exactly 252 bytes makes the search needle 256 bytes, which truncates the default skip distance to zero and turns the search into a CPU bound loop on a small body. A single small request can keep one core busy and deny service to other requests handled by the same process. The issue is fixed in @fastify/busboy 3.2.1, which widens the skip table so the skip distance is preserved. Users should upgrade to 3.2.1.
Affected products
- Fastify/Busyboy: from 3.1.0 before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Fastify/Busyboy 3.2.1. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/busboy/security/advisories/GHSA-xjh9-v7x6-24jw
Get alerted when CVE-2026-19484 or the next vulnerability affects your stack