What’s Vulnerable › Vulnerabilities
CVE-2026-19500: SureForms contains an uncontrolled resource consumption vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-09-03
- Weakness: CWE-400
Description
The Entries component in Brainstorm Force SureForms version, less than 2.12.3, does not enforce adequate limits on user-controlled form fields or submitted content during processing and rendering, which allows a remote attacker to exhaust server resources, prevent administrators from accessing the Entries interface, and trigger HTTP 500 errors via crafted form submissions.
Affected products
- SureForms: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: SureForms 2.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/typedefabcd1234ntd/CVE-2026-19500-poc
- https://sureforms.com/
- https://github.com/typedefabcd1234ntd/CVE-2026-19500-poc
Get alerted when CVE-2026-19500 or the next vulnerability affects your stack