What’s Vulnerable › Vulnerabilities
CVE-2026-19589: Packer vulnerable to arbitrary file write via crafted plugin archive during installation
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-23
- Weakness: CWE-22
Description
Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
Affected products
- HashiCorp Packer: from 1.7.0 before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: HashiCorp Packer 1.16.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19589 or the next vulnerability affects your stack