What’s Vulnerable › Vulnerabilities
CVE-2026-1961: Forman: foreman: remote code execution via command injection in websocket proxy
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-26 · updated 2026-10-20
- Weakness: CWE-78
Description
A flaw was found in Foreman. A remote attacker could exploit a command injection vulnerability in Foreman's WebSocket proxy implementation. This vulnerability arises from the system's use of unsanitized hostname values from compute resource providers when constructing shell commands. By operating a malicious compute resource server, an attacker could achieve remote code execution on the Foreman server when a user accesses VM VNC console functionality. This could lead to the compromise of sensitive credentials and the entire managed infrastructure.
Affected products
- Red Hat Satellite 6: from 6.16 before 6.16.7; from 6.17 before 6.17.7; from 6.18 before 6.18.4; 6.0 — fixed in 6.16.7, 6.17.7, 6.18.4
- foreman: before 3.16.3; from 3.17.0 before 3.17.2; from 3.18.0 before 3.18.1 — fixed in 3.16.3, 3.17.2, 3.18.1
How to fix
Upgrade to a fixed version: Red Hat Satellite 6 6.16.7, 6.17.7, 6.18.4; foreman 3.16.3, 3.17.2, 3.18.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:5968
- https://access.redhat.com/errata/RHSA-2026:5970
- https://access.redhat.com/errata/RHSA-2026:5971
- https://access.redhat.com/security/cve/CVE-2026-1961
- https://bugzilla.redhat.com/show_bug.cgi?id=2437036
- http://www.openwall.com/lists/oss-security/2026/03/27/3
- https://access.redhat.com/errata/RHSA-2026:5968
- https://access.redhat.com/errata/RHSA-2026:5970
- https://access.redhat.com/errata/RHSA-2026:5971
- https://access.redhat.com/security/cve/CVE-2026-1961
- https://bugzilla.redhat.com/show_bug.cgi?id=2437036
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-1961.json
Get alerted when CVE-2026-1961 or the next vulnerability affects your stack