What’s Vulnerable › Vulnerabilities
CVE-2026-19642: Out-of-bounds write in the Base64 decoder in Amazon aws-sdk-cpp
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-23
- Weakness: CWE-787
Description
An out-of-bounds write issue in the Base64 decoder in Amazon aws-sdk-cpp before 1.11.862 might allow a remote authenticated user to cause a crash or heap memory corruption in an application that processes crafted Base64-encoded input. To remediate this issue, users should upgrade to version 1.11.862.
Affected products
- aws-sdk-cpp: before 1.11.862 — fixed in 1.11.862
How to fix
Upgrade to a fixed version: aws-sdk-cpp 1.11.862. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-080-aws/
- https://github.com/aws/aws-sdk-cpp/releases/tag/1.11.862
- https://github.com/aws/aws-sdk-cpp/security/advisories/GHSA-wxx3-prfc-69xx
Get alerted when CVE-2026-19642 or the next vulnerability affects your stack