What’s Vulnerable › Vulnerabilities

CVE-2026-19650: Cross-Site Request Forgery (CSRF) in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.11.11, 19.0 before 19.0.8, 19.1 before 19.1.6, and 19.2 before 19.2.4 that under certain conditions could have allowed an unauthenticated user to execute mutations via GET requests due to improper request validation in GraphQL multiplex query handling.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.11, 19.0.8, 19.1.6, 19.2.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-19650 or the next vulnerability affects your stack