What’s Vulnerable › Vulnerabilities
CVE-2026-19654: Rsyslog: a configuration-dependent issue in rsyslog's optional imptcp input module can allow an unauthenticated remote peer to crash rsyslogd
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-30
- Weakness: CWE-125
Description
A unauthenticated remote peer may lead rsyslogd to crash due to a flaw in the optional imptcp module. A crafted input sequence during oversize-frame recovery can cause an invalid internal message length and terminate rsyslogd. No confidentiality or integrity impact, privilege escalation, or code execution has been identified. imtcp and the default imptcp framing modes are not affected.
Affected products
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0, 10.0 (and their updates)
- rsyslog: from 8.36.0 before 8.2608.0 — fixed in 8.2608.0
- Red Hat Enterprise Linux 10: all versions — fixed in 0:8.2510.0-5.el10_2.1
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:8.2412.0-1.el10_0.1
- Red Hat Enterprise Linux 8: all versions — fixed in 0:8.2102.0-15.el8_10.3
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:8.2102.0-7.el8_6.2
- Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On: all versions — fixed in 0:8.2102.0-7.el8_6.2
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:8.2102.0-13.el8_8.1
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 0:8.2102.0-13.el8_8.1
- Red Hat Enterprise Linux 9: all versions — fixed in 0:8.2510.0-2.el9_8.1
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:8.2102.0-113.el9_2.3
- Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions: all versions — fixed in 0:8.2310.0-4.el9_4.1
- Red Hat Enterprise Linux 9.6 Extended Update Support: all versions — fixed in 0:8.2412.0-1.el9_6.2
- Red Hat Update Infrastructure 5: all versions — fixed in 1790241900
How to fix
Upgrade to a fixed version: rsyslog 8.2608.0; Red Hat Enterprise Linux 10 0:8.2510.0-5.el10_2.1; Red Hat Enterprise Linux 10.0 Extended Update Support 0:8.2412.0-1.el10_0.1; Red Hat Enterprise Linux 8 0:8.2102.0-15.el8_10.3; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:8.2102.0-7.el8_6.2; Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On 0:8.2102.0-7.el8_6.2; Red Hat Enterprise Linux 8.8 Telecommunications Update Service 0:8.2102.0-13.el8_8.1; Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions 0:8.2102.0-13.el8_8.1; Red Hat Enterprise Linux 9 0:8.2510.0-2.el9_8.1; Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions 0:8.2102.0-113.el9_2.3; Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions 0:8.2310.0-4.el9_4.1; Red Hat Enterprise Linux 9.6 Extended Update Support 0:8.2412.0-1.el9_6.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:66405
- https://access.redhat.com/errata/RHSA-2026:67583
- https://access.redhat.com/errata/RHSA-2026:67584
- https://access.redhat.com/errata/RHSA-2026:71603
- https://access.redhat.com/errata/RHSA-2026:80817
- https://access.redhat.com/errata/RHSA-2026:84571
- https://access.redhat.com/errata/RHSA-2026:84576
- https://access.redhat.com/errata/RHSA-2026:86124
- https://access.redhat.com/errata/RHSA-2026:87408
- https://access.redhat.com/errata/RHSA-2026:91582
- https://access.redhat.com/security/cve/CVE-2026-19654
- https://bugzilla.redhat.com/show_bug.cgi?id=2502868
Get alerted when CVE-2026-19654 or the next vulnerability affects your stack