What’s Vulnerable › Vulnerabilities
CVE-2026-19712: Masteriyo LMS < 2.3.3 - Instructor+ Stored XSS via Quiz Description
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-26
- Weakness: CWE-79
Description
The Masteriyo LMS WordPress plugin before 2.3.3 does not sanitise and escape a quiz field before outputting it back in a page, and grants its instructor role the ability to store unfiltered HTML, allowing such users to perform Stored Cross-Site Scripting attacks against any visitor of the affected page, including administrators. This affects default single-site installations. Sites running multisite, or defining DISALLOW_UNFILTERED_HTML, are not affected as the capability is not granted there.
Affected products
- Masteriyo LMS: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: Masteriyo LMS 2.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19712 or the next vulnerability affects your stack