What’s Vulnerable › Vulnerabilities
CVE-2026-19718: BlogVault, MalCare and WP Remote 5.16 - 6.62 - Unauthenticated Site Takeover via Connection Key Recovery
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-26
- Weakness: CWE-287
Description
The BlogVault Backup & Staging WordPress plugin before 6.65, MalCare WordPress Security Plugin WordPress plugin before 6.65, The WP Remote WordPress Plugin WordPress plugin before 6.65 do not prevent unauthenticated users from obtaining data derived from the secret that binds a site to its remote management service, and generate that secret with a weak pseudo-random number generator, allowing attackers to recover it and gain administrative access to the site.
Affected products
- BlogVault Backup & Staging: from 5.16 before 6.65 — fixed in 6.65
- MalCare WordPress Security Plugin: from 5.16 before 6.65 — fixed in 6.65
- The WP Remote WordPress Plugin: from 5.16 before 6.65 — fixed in 6.65
How to fix
Upgrade to a fixed version: BlogVault Backup & Staging 6.65; MalCare WordPress Security Plugin 6.65; The WP Remote WordPress Plugin 6.65. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19718 or the next vulnerability affects your stack