What’s Vulnerable › Vulnerabilities
CVE-2026-19726: Visualizer < 4.0.7 - Contributor+ Cross-User Chart Configuration Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-26
- Weakness: CWE-863
Description
The Visualizer WordPress plugin before 4.0.7 does not properly authorise access to the configuration of its charts, allowing users with the Contributor role and above to read the full configuration of any chart on the site, including charts the Visualizer WordPress plugin before 4.0.7's own interface denies them, and to retrieve every chart's configuration in a single request. The disclosed configuration can include the credentials of a remote data source a chart reads from.
Affected products
- Visualizer: before 4.0.7 — fixed in 4.0.7
How to fix
Upgrade to a fixed version: Visualizer 4.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19726 or the next vulnerability affects your stack