What’s Vulnerable › Vulnerabilities
CVE-2026-19768
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-28
- Weakness: CWE-94
Description
Improper control of generation of code ('Code Injection') in the settings feature in Devolutions PowerShell Universal 2026.2.3 and earlier allows an authenticated user with settings management permission to execute arbitrary PowerShell code via a crafted setting value that is not properly escaped when written to the settings configuration file.
Affected products
- Devolutions PowerShell Universal: before 2026.2.4 — fixed in 2026.2.4
How to fix
Upgrade to a fixed version: Devolutions PowerShell Universal 2026.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19768 or the next vulnerability affects your stack