What’s Vulnerable › Vulnerabilities
CVE-2026-2003: PostgreSQL oidvector discloses a few bytes of memory
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-1287
Description
Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
Affected products
- PostgreSQL: from 14.0 before 14.21; from 15.0 before 15.16; from 16.0 before 16.12; from 17.0 before 17.8; from 18.0 before 18.2 — fixed in 14.21, 15.16, 16.12, 17.8, 18.2
How to fix
Upgrade to a fixed version: PostgreSQL 14.21, 15.16, 16.12, 17.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2003 or the next vulnerability affects your stack