What’s Vulnerable › Vulnerabilities
CVE-2026-20034: Cisco Unity Connection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-10-26
- Weakness: CWE-35
Description
A vulnerability in the web-based management interface of Cisco Unity Connection could allow an authenticated, remote attacker to execute arbitrary code on an affected device. This vulnerability is due to insufficient validation of user-supplied input. An attacker could exploit this vulnerability by submitting a crafted API request. A successful exploit could allow the attacker to execute arbitrary code as root, possibly resulting in the complete compromise of a targeted device. To exploit this vulnerability, the attacker must have valid user credentials on the affected device.
Affected products
- Cisco Unity Connection: before 14.0; 14.0, 14su1, 14su2, 14su3, 14su4, 15.0 (+3) — fixed in 14.0
How to fix
Upgrade to a fixed version: Cisco Unity Connection 14.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20034 or the next vulnerability affects your stack