What’s Vulnerable › Vulnerabilities

CVE-2026-2005: PostgreSQL pgcrypto heap buffer overflow executes arbitrary code

Description

Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 14.21, 15.16, 16.12, 17.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2005 or the next vulnerability affects your stack