What’s Vulnerable › Vulnerabilities

CVE-2026-2006: PostgreSQL missing validation of multibyte character length executes arbitrary code

Description

Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun. That suffices to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 14.21, 15.16, 16.12, 17.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2006 or the next vulnerability affects your stack