What’s Vulnerable › Vulnerabilities
CVE-2026-20069: Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense Software VPN Web Services Client-Side Request Smuggling Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-04 · updated 2026-08-11
- Weakness: CWE-444
Description
A vulnerability in the VPN web services component of Cisco Secure Firewall Adaptive Security Appliance (ASA) Software and Cisco Secure Firewall Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to conduct browser-based attacks against users of an affected device. This vulnerability is due to improper validation of HTTP requests. An attacker could exploit this vulnerability by persuading a user to visit a website that is designed to pass malicious HTTP requests to a device that is running Cisco Secure Firewall ASA Software or Cisco Secure FTD Software and has web services endpoints supporting VPN features enabled. A successful exploit could allow the attacker to reflect malicious input from the affected device to the browser that is in use and conduct browser-based attacks, including cross-site scripting (XSS) attacks. The attacker is not able to directly impact the affected device.
Affected products
- Cisco ASA Software: from 9.12.1 before 9.16.4.85; from 9.17.1 before 9.18.4.66; from 9.19.1 before 9.20.4; from 9.22.1.1 before 9.22.2.4; from 9.23.1 before 9.23.1.7 — fixed in 9.16.4.85, 9.18.4.66, 9.20.4, 9.22.2.4, 9.23.1.7
- Cisco Firepower Threat Defense Software: from 6.4.0 before 7.0.9; from 7.1.0 before 7.2.11; from 7.3.0 before 7.4.3; from 7.6.0 before 7.6.4; from 7.7.0 before 7.7.11 — fixed in 7.0.9, 7.2.11, 7.4.3, 7.6.4, 7.7.11
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.16.4.85, 9.18.4.66, 9.20.4, 9.22.2.4; Cisco Firepower Threat Defense Software 7.0.9, 7.2.11, 7.4.3, 7.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20069 or the next vulnerability affects your stack