What’s Vulnerable › Vulnerabilities
CVE-2026-2007: PostgreSQL pg_trgm heap buffer overflow writes pattern onto server memory
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-07-15
- Weakness: CWE-122
Description
Heap buffer overflow in PostgreSQL pg_trgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the viability of attacks that lead to privilege escalation. PostgreSQL 18.1 and 18.0 are affected.
Affected products
- PostgreSQL: from 18.0 before 18.2 — fixed in 18.2
How to fix
Upgrade to a fixed version: PostgreSQL 18.2. Check the vendor advisory for mitigations.
References
- https://www.postgresql.org/support/security/CVE-2026-2007/
- https://access.redhat.com/errata/RHSA-2026:19009
- https://access.redhat.com/errata/RHSA-2026:8756
- https://access.redhat.com/security/cve/CVE-2026-2007
- https://bugzilla.redhat.com/show_bug.cgi?id=2439320
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2007.json
Get alerted when CVE-2026-2007 or the next vulnerability affects your stack