What’s Vulnerable › Vulnerabilities
CVE-2026-20075: Cisco Evolved Programmable Network Manager and Cisco Prime Infrastructure Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Evolved Programmable Network Manager (EPNM) and Cisco Prime Infrastructure could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against users of the interface of an affected system. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by inserting malicious code into specific data fields in the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit this vulnerability, an attacker must have valid administrative credentials.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): through 7.0; from 7.1.0 before 7.1.4.1; from 8.1.0 through 8.1.2.1; 8.0.0 — fixed in 7.1.4.1
- Cisco Prime Infrastructure: through 3.9; from 3.10.0 through 3.10.6
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 7.1.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20075 or the next vulnerability affects your stack