What’s Vulnerable › Vulnerabilities

CVE-2026-20144: Sensitive Information Disclosure in ''_internal'' index in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.2.0, 10.0.2, 9.4.7, 9.3.8, and 9.2.11, and Splunk Cloud Platform versions below 10.2.2510.0, 10.1.2507.11, 10.0.2503.9, and 9.3.2411.120, a user of a Splunk Search Head Cluster (SHC) deployment who holds a role with access to the the Splunk _internal index could view the Security Assertion Markup Language (SAML) configurations for Attribute query requests (AQRs) or Authentication extensions in plain text within the conf.log file, depending on which feature is configured.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.2, 9.2.11, 9.3.8, 9.4.7; Splunk Cloud Platform 10.0.2503.9, 10.1.2507.11, 9.3.2411.120. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-20144 or the next vulnerability affects your stack