What’s Vulnerable › Vulnerabilities
CVE-2026-20147: Cisco Identity Services Engine Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-77
Description
A vulnerability in Cisco ISE and Cisco ISE-PIC could allow an authenticated, remote attacker to execute arbitrary commands on the underlying operating system of an affected device. To exploit this vulnerability, the attacker must have valid administrative credentials. This vulnerability is due to insufficient validation of user-supplied input. An attacker could exploit this vulnerability by sending a crafted HTTP request to an affected device. A successful exploit could allow the attacker to obtain user-level access to the underlying operating system and then elevate privileges to root. In single-node ISE deployments, successful exploitation of this vulnerability could cause the affected ISE node to become unavailable, resulting in a denial of service (DoS) condition. In that condition, endpoints that have not already authenticated would be unable to access the network until the node is restored.
Affected products
- Cisco Identity Services Engine: before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch10, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4 (+35) — fixed in 3.1.0
- Cisco Identity Services Engine Passive Identity Connector: before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch10, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4 (+32) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1.0; Cisco Identity Services Engine Passive Identity Connector 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20147 or the next vulnerability affects your stack