What’s Vulnerable › Vulnerabilities
CVE-2026-20148: Cisco Identity Services Engine Path Traversal Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-22
Description
A vulnerability in Cisco ISE and Cisco ISE-PIC could allow an authenticated, remote attacker to perform path traversal attacks on the underlying operating system and read arbitrary files. To exploit this vulnerability, the attacker must have valid administrative credentials. This vulnerability is due to improper validation of user-supplied input. An attacker could exploit this vulnerability by sending a crafted HTTP request to an affected system. A successful exploit could allow the attacker to access sensitive files on the affected system.
Affected products
- Cisco Identity Services Engine: before 3.1; 3.1.0, 3.1.0-patch1, 3.1.0-patch10, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4 (+35) — fixed in 3.1
- Cisco Identity Services Engine Passive Identity Connector: before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch10, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4 (+32) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1; Cisco Identity Services Engine Passive Identity Connector 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20148 or the next vulnerability affects your stack