What’s Vulnerable › Vulnerabilities
CVE-2026-20155: Cisco Evolved Programmable Network Manager Improper Authorization Vulnerability
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-862
Description
A vulnerability in the web-based management interface of Cisco Evolved Programmable Network Manager (EPNM) could allow an authenticated, remote attacker with low privileges to access sensitive information that they are not authorized to access. This vulnerability is due to improper authorization checks on a REST API endpoint of an affected device. An attacker could exploit this vulnerability by querying the affected endpoint. A successful exploit could allow the attacker to view session information of active Cisco EPNM users, including users with administrative privileges, which could result in the affected device being compromised.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 8.1.2 — fixed in 8.1.2
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 8.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20155 or the next vulnerability affects your stack