What’s Vulnerable › Vulnerabilities
CVE-2026-20162: Stored Cross-Site Scripting (XSS) through Path Traversal in Splunk Enterprise
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
In Splunk Enterprise versions below 10.2.0, 10.0.3, 9.4.9, and 9.3.9, and Splunk Cloud Platform versions below 10.2.2510.4, 10.1.2507.15, 10.0.2503.11, and 9.3.2411.123, a low-privileged user who does not hold the "admin" or "power" Splunk roles could craft a malicious payload when creating a View (Settings - User Interface - Views) at the `/manager/launcher/data/ui/views/_new` endpoint leading to a Stored Cross-Site Scripting (XSS) through a path traversal vulnerability. This could result in execution of unauthorized JavaScript code in the browser of a user. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The authenticated user should not be able to exploit the vulnerability at will.
Affected products
- Splunk Enterprise: from 9.3.0 before 9.3.9; from 9.4.0 before 9.4.9; from 10.0.0 before 10.0.3 — fixed in 10.0.3, 9.3.9, 9.4.9
- Splunk Cloud Platform: from 9.3.2411 before 9.3.2411.123; from 10.0.2503 before 10.0.2503.11; from 10.1.2507 before 10.1.2507.15; from 10.2.2510 before 10.2.2510.4 — fixed in 10.0.2503.11, 10.1.2507.15, 10.2.2510.4, 9.3.2411.123
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.3, 9.3.9, 9.4.9; Splunk Cloud Platform 10.0.2503.11, 10.1.2507.15, 10.2.2510.4, 9.3.2411.123. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20162 or the next vulnerability affects your stack