What’s Vulnerable › Vulnerabilities
CVE-2026-20223: Cisco Secure Workload Unauthorized API Access Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-20 · updated 2026-07-23
- Weakness: CWE-306
Description
A vulnerability in the access validation of internal REST APIs of Cisco Secure Workload could allow an unauthenticated, remote attacker to access site resources with the privileges of the Site Admin role. This vulnerability is due to insufficient validation and authentication when accessing REST API endpoints. An attacker could exploit this vulnerability if they are able to send a crafted API request to an affected endpoint. A successful exploit could allow the attacker to read sensitive information and make configuration changes across tenant boundaries with the privileges of the Site Admin user.
Affected products
- Cisco Secure Workload: before 3.10.8.3; from 4.0 before 4.0.3.17 — fixed in 3.10.8.3, 4.0.3.17
How to fix
Upgrade to a fixed version: Cisco Secure Workload 3.10.8.3, 4.0.3.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20223 or the next vulnerability affects your stack