What’s Vulnerable › Vulnerabilities
CVE-2026-20251: Remote Code Execution through Deserialization of Untrusted Data in Splunk Secure Gateway
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 32.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-06-17
- Weakness: CWE-502
Description
In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, Splunk Cloud Platform versions below 10.3.2512.12, 10.2.2510.14, 10.1.2507.22, and 9.3.2411.132, and Splunk Secure Gateway versions below 3.10.6, 3.9.20, and 3.8.67, a low-privileged user that does not hold the 'admin' or 'power' Splunk roles could perform a Remote Code Execution (RCE) through the Splunk Secure Gateway app.<br><br>The Remote Code Execution is possible because of unsafe deserialization of App Key Value Store (KV Store) data through the ‘jsonpickle’ Python library, which reconstructs arbitrary Python objects from specially crafted JavaScript Object Notation (JSON) without adequate validation.
Affected products
- Splunk Enterprise: from 9.3.0 before 9.3.13; from 9.4.0 before 9.4.12; from 10.0.0 before 10.0.7; from 10.2.0 before 10.2.4 — fixed in 10.0.7, 10.2.4, 9.3.13, 9.4.12
- Splunk Cloud Platform: from 9.3.2411 before 9.3.2411.132; from 10.1.2507 before 10.1.2507.22; from 10.2.2510 before 10.2.2510.14; from 10.3.2512 before 10.3.2512.12 — fixed in 10.1.2507.22, 10.2.2510.14, 10.3.2512.12, 9.3.2411.132
- Splunk Secure Gateway: from 3.8.0 before 3.8.67; from 3.9.0 before 3.9.20; from 3.10.0 before 3.10.6 — fixed in 3.10.6, 3.8.67, 3.9.20
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.7, 10.2.4, 9.3.13, 9.4.12; Splunk Cloud Platform 10.1.2507.22, 10.2.2510.14, 10.3.2512.12, 9.3.2411.132; Splunk Secure Gateway 3.10.6, 3.8.67, 3.9.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20251 or the next vulnerability affects your stack