What’s Vulnerable › Vulnerabilities

CVE-2026-20255: Improper Input Validation through Classic Dashboards in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, and Splunk Cloud Platform versions below 10.3.2512.13, 10.2.2510.15, 10.1.2507.23, and 9.3.2411.132, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious classic dashboard that exfiltrates sensitive data to an external server. The vulnerability exists because URL validation on the external content dialog is incomplete, which can allow for requests to untrusted domains when a user interacts with a crafted dashboard.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.7, 10.2.4, 9.3.13, 9.4.12; Splunk Cloud Platform 10.1.2507.23, 10.2.2510.15, 10.3.2512.13, 9.3.2411.132. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-20255 or the next vulnerability affects your stack