What’s Vulnerable › Vulnerabilities
CVE-2026-20257: Improper Input Validation through Classic Dashboard CSS in Splunk Enterprise
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-06-17
- Weakness: CWE-20
Description
In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, and Splunk Cloud Platform versions below 10.3.2512.13, 10.2.2510.15, 10.1.2507.23, and 9.3.2411.132, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a classic dashboard that exfiltrates sensitive data from the browser of a higher-privileged user who views it. The exfiltration is possible because classic dashboard panels do not fully validate style attribute values, which can allow for requests to reach external domains outside the configured Trusted Domains List. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The low-privileged user should not be able to exploit the vulnerability at will.
Affected products
- Splunk Enterprise: from 9.3.0 before 9.3.13; from 9.4.0 before 9.4.12; from 10.0.0 before 10.0.7; from 10.2.0 before 10.2.4 — fixed in 10.0.7, 10.2.4, 9.3.13, 9.4.12
- Splunk Cloud Platform: from 9.3.2411 before 9.3.2411.132; from 10.1.2507 before 10.1.2507.23; from 10.2.2510 before 10.2.2510.15; from 10.3.2512 before 10.3.2512.13 — fixed in 10.1.2507.23, 10.2.2510.15, 10.3.2512.13, 9.3.2411.132
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.7, 10.2.4, 9.3.13, 9.4.12; Splunk Cloud Platform 10.1.2507.23, 10.2.2510.15, 10.3.2512.13, 9.3.2411.132. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20257 or the next vulnerability affects your stack