What’s Vulnerable › Vulnerabilities

CVE-2026-20258: Stored Cross-Site Scripting (XSS) through Classic Dashboard in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, and Splunk Cloud Platform versions below 10.3.2512.11, 10.2.2510.15, 10.1.2507.23, and 9.3.2411.132, a low-privileged user that does not hold the "admin" or "power" Splunk roles could store a malicious script in a classic dashboard HTML panel, causing unauthorized JavaScript code to execute in the browser of another user. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The low-privileged user should not be able to exploit the vulnerability at will.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.7, 10.2.4, 9.3.13, 9.4.12; Splunk Cloud Platform 10.1.2507.23, 10.2.2510.15, 10.3.2512.11, 9.3.2411.132. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-20258 or the next vulnerability affects your stack