What’s Vulnerable › Vulnerabilities
CVE-2026-20296: SPL Command Safeguards Bypass through Cross-Site Request Forgery (CSRF) in Deployment Server in Splunk Enterprise
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-07-24
- Weakness: CWE-352
Description
In Splunk Enterprise versions below 10.4.1, 10.2.5, 10.0.8, and 9.4.13, and Splunk Cloud Platform versions below 10.5.2605.0, 10.4.2604.7, 10.3.2512.16, 10.2.2510.18, and 10.1.2507.24, an attacker could trick a user that holds a role with the `list_deployment_server` capability into running arbitrary Search Processing Language (SPL) searches on their behalf as `splunk-system-user`, allowing for access to stored credentials and indexed data.<br><br>The vulnerability is possible because Deployment Server endpoints in Splunk Web do not validate Cross-Site Request Forgery (CSRF) tokens on GET requests, and caller-supplied input is not correctly neutralized before it is placed into an SPL search.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.13; from 10.0.0 before 10.0.8; from 10.2.0 before 10.2.5; 10.4.0 — fixed in 10.0.8, 10.2.5, 9.4.13
- Splunk Cloud Platform: from 10.1.2507 before 10.1.2507.24; from 10.2.2510 before 10.2.2510.18; from 10.3.2512 before 10.3.2512.16; from 10.4.2604 before 10.4.2604.7 — fixed in 10.1.2507.24, 10.2.2510.18, 10.3.2512.16, 10.4.2604.7
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.8, 10.2.5, 9.4.13; Splunk Cloud Platform 10.1.2507.24, 10.2.2510.18, 10.3.2512.16, 10.4.2604.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-20296 or the next vulnerability affects your stack