What’s Vulnerable › Vulnerabilities
CVE-2026-2052: Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-02 · updated 2026-10-26
- Weakness: CWE-94
Description
The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.
Affected products
- Marketing Fire, LLC Widget Options - Extended: through 5.3.2
- marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets: through 4.2.2
References
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L495
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L534
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/widgets/gutenberg/gutenberg-toolbar.php#L843
- https://plugins.trac.wordpress.org/changeset/3481338/
- https://plugins.trac.wordpress.org/changeset/3514411/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/68023557-fc92-4cf6-96b4-405ff5a5fd5a?source=cve
Get alerted when CVE-2026-2052 or the next vulnerability affects your stack