What’s Vulnerable › Vulnerabilities
CVE-2026-21267: Dreamweaver Desktop | Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') (CWE-78)
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-08-28
- Weakness: CWE-78
Description
Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an attacker. Exploitation of this issue requires user interaction in that a victim must open a malicious file and scope is changed.
Affected products
- Adobe Dreamweaver Desktop: before 21.7 — fixed in 21.7
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21267 or the next vulnerability affects your stack