What’s Vulnerable › Vulnerabilities
CVE-2026-21271: Dreamweaver Desktop | Improper Input Validation (CWE-20)
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-08-28
- Weakness: CWE-20
Description
Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file and scope is changed.
Affected products
- Adobe Dreamweaver Desktop: before 21.7 — fixed in 21.7
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21271 or the next vulnerability affects your stack