What’s Vulnerable › Vulnerabilities
CVE-2026-21274: Dreamweaver Desktop | Incorrect Authorization (CWE-863)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-08-28
- Weakness: CWE-863
Description
Dreamweaver Desktop versions 21.6 and earlier are affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could leverage this vulnerability to bypass security measures and execute unauthorized code. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Dreamweaver Desktop: before 21.7 — fixed in 21.7
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21274 or the next vulnerability affects your stack