What’s Vulnerable › Vulnerabilities
CVE-2026-21288: Illustrator | NULL Pointer Dereference (CWE-476)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-08-28
- Weakness: CWE-476
Description
Illustrator versions 29.8.3, 30.0 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to application denial-of-service. An attacker could exploit this vulnerability to crash the application, causing disruption to services. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 29.0 before 29.8.4; 30.0 — fixed in 29.8.4
How to fix
Upgrade to a fixed version: Adobe Illustrator 29.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21288 or the next vulnerability affects your stack