What’s Vulnerable › Vulnerabilities
CVE-2026-21361: Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-08-28
- Weakness: CWE-79
Description
Adobe Commerce versions 2.4.9-alpha3, 2.4.8-p3, 2.4.7-p8, 2.4.6-p13, 2.4.5-p15, 2.4.4-p16 and earlier are affected by a stored Cross-Site Scripting (XSS) vvulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality, and integrity impact to high. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13 (+62) — fixed in 2.4.4
- Adobe Commerce: before 1.3.3; 1.3.3, 1.3.3-p1, 1.3.3-p10, 1.3.3-p11, 1.3.3-p12, 1.3.3-p13 (+57) — fixed in 1.3.3
- Adobe Magento: before 2.4.5; 2.4.5, 2.4.5-p1, 2.4.5-p10, 2.4.5-p11, 2.4.5-p12, 2.4.5-p13 (+43) — fixed in 2.4.5
- Adobe Commerce: through 2.4.9-alpha3, 2.4.8-p3, 2.4.7-p8, 2.4.6-p13, 2.4.5-p15, 2.4.4-p16
- Adobe Commerce: through 1.5.3-alpha3, 1.5.2-p3, 1.4.2-p8, 1.3.5-p13, 1.3.4-p15, 1.3.3-p16
- Adobe Magento Open Source: through 2.4.9-alpha3, 2.4.8-p3, 2.4.7-p8, 2.4.6-p13, 2.4.5-p15
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Commerce 1.3.3; Adobe Magento 2.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21361 or the next vulnerability affects your stack