What’s Vulnerable › Vulnerabilities
CVE-2026-21391: Improper Claim Validation in PingAM OIDC Provider
- Severity: critical (CVSS 9.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-18
- Weakness: CWE-290
Description
An improper validation vulnerability exists within PingAM where a well-crafted request allows arbitrary or protected ID Token claims to be set or overridden. In certain configurations this could allow an attacker to bypass authentication controls via spoofing leading to privilege escalation or impersonation.
Affected products
- Ping Identity PingAM: from 8.0.0 through 8.0.2; from 7.5.0 through 7.5.2; from 7.4.0 through 7.4.2; from 7.3.0 through 7.3.3; from 7.2.0 through 7.2.2; from 7.1.0 through 7.1.4 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Ping Identity PingAM 7.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21391 or the next vulnerability affects your stack