What’s Vulnerable › Vulnerabilities
CVE-2026-21516: GitHub Copilot for Jetbrains Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-08-19
- Weakness: CWE-77
Description
Improper neutralization of special elements used in a command ('command injection') in Github Copilot allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft GitHub Copilot Plugin for JetBrains IDEs: before 1.5.63-243 — fixed in 1.5.63-243
- Microsoft GitHub Copilot Plugin for JetBrains IDEs: from 1.0.0 before 1.5.63 — fixed in 1.5.63
How to fix
Upgrade to a fixed version: Microsoft GitHub Copilot Plugin for JetBrains IDEs 1.5.63-243; Microsoft GitHub Copilot Plugin for JetBrains IDEs 1.5.63. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21516 or the next vulnerability affects your stack