What’s Vulnerable › Vulnerabilities
CVE-2026-21570
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-17 · updated 2026-08-10
- Weakness: CWE-94
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 9.6.0, 10.0.0, 10.1.0, 10.2.0, 11.0.0, 11.1.0, 12.0.0, and 12.1.0 of Bamboo Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.6, allows an authenticated attacker to execute malicious code on the remote system. Atlassian recommends that Bamboo Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bamboo Data Center 9.6: Upgrade to a release greater than or equal to 9.6.24 Bamboo Data Center 10.2: Upgrade to a release greater than or equal to 10.2.16 Bamboo Data Center 12.1: Upgrade to a release greater than or equal to 12.1.3 See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center from the download center ([https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
Affected products
- Atlassian Bamboo: from 9.6.1 before 9.6.24; from 10.0.0 before 10.2.16; from 11.0.0 before 12.1.3 — fixed in 10.2.16, 12.1.3, 9.6.24
How to fix
Upgrade to a fixed version: Atlassian Bamboo 10.2.16, 12.1.3, 9.6.24. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1721271371
- https://jira.atlassian.com/browse/BAM-26342
Get alerted when CVE-2026-21570 or the next vulnerability affects your stack